Litres Baner
Справочник по настройке сетевого оборудования Cisco

Александр Владимирович Меньшуткин
Справочник по настройке сетевого оборудования Cisco

Введение

Об этой книги

В процессе подготовки к получению сертификатов нарабатывался материал, файлы с командами и выводами show и debug которые приходилось систематизировать и объединять в один большой файл для удобства поиска, изучения и хранения. Результатом это работы и стала эта книга и она является справочным материалом для настройки сетевого оборудования компании Cisco. К сожаленью должен предупредить, что возможно не корректное отображение команд show и debug, а также возможны опечатки и ошибки, но я буду продолжать дополнять и редактировать это произведение по этому не судите строго, всё отраженные в данной книге команды были отработаны лично мною. Также стоит заметить, что некоторые команды на новом оборудование могут иметь другой синтаксис.

С обозначением, всё достаточно просто, адреса на оборудование совпадают с номером устройства, к примеру 10.0.21.1 принадлежит маршрутизатору r1, по третьему октету видно что он соединен с маршрутизатором r2, другой пример адрес 10.0.214.1 общий для маршрутизаторов r1, r2, r4. Сеть 10.0.12.0 также находится между ними где маршрутизатору r1 принадлежит адрес 10.0.12.1, а r2 10.0.12.2. Также в некоторых примерах есть Frame-relay не обращайте внимание, просто на нем было на тот момент проще сделать, хотя я лично не встречал данного типа сетей.

Первоначальная настройка коммутаторов и маршрутизаторов

Оборудование Cisco имеет два основных режима работы: пользовательский (user mode) и привилегированный (privileged mode). Пользовательский режим использует приглашение

Router>

В данном режиме имеется множественные ограничения, просмотреть, что доступно из данного режима можно вводом знака вопроса ?, который также является подсказкой. Для того чтобы изменить конфигурацию устройства необходимо войти в привилегированный режим, для этого вводиться команда enable

Router>enable

И переходим в привилегированный режим:

Router#

Для того чтобы приступить к настройке устройства, необходимо перейти в режим настройки командой configure terminal

Router#configure terminal

Переходим в режим глобального конфигурирования:

Router(config)#

Для выхода из этого режима можно воспользоваться командой exit, end или Ctrl+Z, команда exit переводит на шаг назад, а две других сразу в привилегированный режим

Для сохранения изменений в устройстве необходимо в привилегированном режиме ввести команду

Router#copy running-config startup-config

или

Router#write

Либо это можно сделать в любом другом режиме, используя команду do:

Router(config)#do copy running-config startup-config

Просмотреть сделанные изменения или конфигурацию, можно путем команды show. К примеру, для просмотра конфигурации достаточно набрать

Router#show running-config

Для просмотра из режима настройки

Router(config)#do show running-config

При этом не надо набирать команду целиком, достаточно набрать sh run, если для устройства команда будет не понятна, оно обозначит не понятный символ символов каретки (^).

Для полного удаления конфигураций, Вам нужно использовать старый маршрутизатор или коммутатор на новом месте, воспользуйтесь командой:

Router#erase startup-config

После этого перегрузите его командой:

Router#reload

Также можно перегрузить устройство в определенное время, Вы хотите это сделать в 20:00 сегодня:

Switch# reload at 20:00

И в определенный день:

Switch# reload at 20:00 jun 10

Также надо помнить, что коммутатор содержит таблицы виртуальных локальных сетей (vlan) в отдельном файле и для их удаления Вам необходимо удалить этот файл или удалить виртуальные локальные сети вручную.

Удаление всех виртуальных локальных сетей:

sw2#delete flash:vlan.dat

Удаление виртуальной локальной сети (vlan) под номером 234:

sw2(config)#no vlan 234

Так же считаю очень полезным знание клавиш редактирования в командной строке, ниже приведена таблица:

Клавиша      Описание

Ctrl+A      Возвращает курсор к началу текущей строки

Ctrl+B      Перемещает курсор на один символ назад

Ctrl+D      Удаляет символ слева от курсора

Ctrl+E      Перемещает курсор в конец строки

Ctrl+F      Перемещает курсор вперед на один символ

Ctrl+K      Удаляет все символы от текущего положения курсора до конца строки

Ctrl+N      Переход на следующую в предыстории сеанса команду

Ctrl+P      Переход на предыдущую в предыстории сеанса команду

Ctrl+T      Меняет местами текущий символ и символ слева от курсора

Ctrl+R      Перерисовывает или вводит заново текущую строку

Ctrl+U      Очищает строку

Ctrl+W      Удаляет слово слева от курсора

Ctrl+X      Удаляет все символы от текущего положения курсора и до начала строки

Ctrl+Y      Вставляет символы, удаленные последними, на место соответствующие текущему положению курсора

Ctrl+Z      Выход из текущего режима конфигурирования и возврат в предыдущий режим

Табуляция      Попытка завершить текущую команду

↑      Переход назад в предыстории команд

↓      Переход вперед в предыстории команд

←      Перевод курсора влево

→      Перевод курсора вправо

Ctrl+^, затем X      Прерывание выполнения любой команды

Пробел Позволяет пролистывать блоками.

Следует знать команды оптимизации запросов, пример:

Switch#show running-config

При вводе Вам будет показана вся конфигурация, но Вы можете оптимизировать запрос, используя команды begin, include, exclude и применяемую только для маршрутизаторов команду section. Как это выглядит на практике:

Switch#show running-config | begin interface

При выводе Вам будет представлена информация с того момента где в строке есть слово interface, соответственно если вы примените include, то получите только те строки, где присутствует интересующая Вас команда:

Switch# show interface | include protocol

Vlan 1 is up, line protocol is up

FastEthernet0/0 is up, line protocol is up

Ваше сетевое оборудование, для удобства, должно иметь имена, задается это командой:

Router(config)#hostname r1

После ввода команды видно как мы назвали маршрутизатор:

r1(config)#

В начале настройки устройства, для удобства работы на нем следует ввести несколько команд, которые я привожу ниже.

Для отключения разрешения символьных имен:

r1(config)#no ip domain-lookup

r1(config)#line console 0

Вводим бесконечное значение тайм-аута, не будет отключаться сессия:

r1(config-line)#exec-timeout 0 0

Делаем синхронизацию вывода не запрошенных сообщений:

r1(config-line)#logging synchronous

r1(config-line)#exit

Для удаленного управления оборудование мы должны ввести следующие команды:

Заводим пользователя и пароль для него и выставляем самый высокий уровень привилегий:

r1(config)#username admin privilege 15 password cisco

Но лучше сделать это вот так:

Заменяем слово password на secret, и Ваш пароль будет защищён.

r1(config)#username admin privilege 15 secret cisco

Настраиваем доступ по SSH, для этого вводим следующие команды:

Нужно указать Ваш домен, имя маршрутизатору мы уже выбрали:

r1(config)#ip domain-name cisco.net

r1(config)#crypto key generate rsa

Далее появиться запрос на размер ключа, ставим 2048, так как желательно самое большое значение, если данное значение ввести не удается ставим максимально возможное.

Вводим нужную версию:

r1(config)#ip ssh version 2

Ниже задаем, сколько подключений возможно, в примере ниже мы установили пять, с 0 по 4, но можем установить и больше:

r1(config)#line vty 0 4

Позволяем вход для локально заданных пользователей:

r1(config-line)#login local

Разрешаем два типа подключений:

r1(config-line)#transport input telnet ssh

Выходим и сохраняемся:

r1(config-line)#end

r1#write

Проверить мы можем командой show running-config, а также show ip ssh.

Посмотреть информацию об открытых сессиях можно командой show sessions, а через show users информацию об активных линиях.

Не забывайте сохраняться после внесения изменений:

r1# copy running-config startup-config

Также для удобства важно подписывать интерфейсы, как показано ниже:

r1(config)#interface f0/0

r1(config-if)#description *** Connects to router r2 ***

И задаём адрес на интерфейсе:

r1(config-if)#ip address 10.1.1.1 255.255.255.0

На этом примере показано изменение скорость и дуплекс на интерфейсе:

sw1#configure terminal

sw1(config)#interface f0/0

sw1(config-if)#speed ?

10 Force 10 Mbps operation

100 Force 100 Mbps operation

auto Enable AUTO speed configuration

sw1(config-if)#duplex ?

auto Enable AUTO duplex configuration

full Force full duplex operation

half Force half-duplex operation

Проверив командой show, мы видим, что по умолчанию на данном интерфейсе установлено авто скорость и дуплекс:

sw1(config-if)#do sh int f0/0 | inc Auto

Auto-duplex, Auto-speed

При попытке задать адрес на интерфейсе коммутатора, мы получим следующие сообщение:

sw1(config-if)#ip address 10.1.1.1 255.255.255.0

% IP addresses may not be configured on L2 links.

И если нам нужно задать на этом порту IP адрес нам надо сделать данный интерфейс интерфейсом третьего уровня, мы должны сделать следующие:

sw1(config-if)#no switchport

И после этого вводим адрес и проверяем интерфейс:

sw1(config-if)#ip address 10.1.1.1 255.255.255.0

sw1(config-if)#do show run interface f0/0

Building configuration…

Current configuration : 83 bytes

 

!

interface FastEthernet0/0

no switchport

ip address 10.1.1.1 255.255.255.0

end

Мы установили нужный адрес.

Если мы хотим отменить данную команду и сделать данный интерфейс интерфейсом второго уровня, вводим:

sw1(config-if)#switchport

Команда shutdown отключает интерфейс, команда no shutdown включает его, на маршрутизаторах интерфейсы по умолчанию выключены.

Мы можем при необходимости изменять MTU на нашем устройстве:

По умолчанию оно 1500, для интерфейсов от 10 до 100 Mb/s область от 1500 до 1998 byte.

sw1(config)#system mtu <указываем значение>

По умолчанию оно 1500,для интерфейсов 1000 Mb/s область от 1500 до 9000 byte.

sw1(config)#system mtu jumbo <указываем значение>

По умолчанию оно 1500 и может быть любым, но не факт, что будет принято.

r1(config)#system mtu routing <указываем значение>

Для того чтобы новое MTU вступило в силу требуется сохранить конфигурацию и перегрузить устройство.

Иногда требуется восстановить настройки интерфейса по умолчанию, это делается командой приведенной ниже:

sw1(config)#default interface f0/0

Building configuration…

Interface FastEthernet0/0 set to default configuration

sw1(config)#

Так же на любом интерфейсе можно создать под интерфейсы, делается это так:

r1(config)#interface s0/0/0

Удалили адрес на интерфейсе:

r1(config-if)#no ip address

Включили интерфейс, как я писал ранее, он по умолчанию отключен:

r1(config-if)#no shutdown

Задаем пару под интерфейсов:

r1(config-if)#interface s0/0/0.1 point-to-point

r1(config-if)#ip address 10.1.1.1 255.255.255.0

r1(config-if)#interface s0/0/0.2 point-to-point

r1(config-if)#ip address 10.1.2.1 255.255.255.0

На одном интерфейсе можно задать несколько адресов:

r1(config)#interface s0/0/0

r1(config-if)#ip address 10.1.1.1 255.255.255.0

Просто добавляем в конце команду secondary:

r1(config-if)#ip address 10.1.2.1 255.255.255.0 secondary

Также на оборудование используется петлевой интерфейс, данный интерфейс удобен для тестирования оборудования, создается он командой:

r1(config)# interface loopback 0

r1(config-if)# ip address 1.1.1.1 255.255.255.255

Мы можем настраивать сразу насколько интерфейсов, это удобно при настройке портов доступа на коммутаторе.

Команда range позволяет это сделать:

sw1(config)#interface range f0/1 – 24

Для обнаружения соседних устройств, в оборудование Cisco используется частный протокол CDP – Cisco Discovery Protocol, протокол может быть включен как глобально на устройстве, так и только на определенном интерфейсе:

Глобальное включение, выключение:

r1(config)#(no) cdp run

r1(config)#interface s0/0/0

Пример включения, выключение на интерфейсе:

r1(config-if)#(no) cdp enable

Просмотр соседних устройств, при добавлении слова detail будет предоставлена более детальная информация о соседних устройствах:

r1#show cdp neighbors (detail)

Следует также помнить об открытом протоколе LLDP – Link Layer Discovery Protocol который также помогает собрать информацию о соседях, он включается командой показанной ниже и проверяется похожими с cdp командами:

r1(config)#run lldp

r1# show lldp ?

Данная ниже команда отобразит информацию о программном обеспечении, самом устройстве и его аппаратной части:

r1#show version

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.1(4)M1, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2011 by Cisco Systems, Inc.

Compiled Tue 14-Jun-11 19:25 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M12, RELEASE SOFTWARE (fc1)

r1 uptime is 13 hours, 43 minutes

System returned to ROM by reload at 18:25:57 MSK Tue May 28 2013

System restarted at 18:27:34 MSK Tue May 28 2013

System image file is "flash0:c2900-universalk9-mz.SPA.151-4.M1.bin"

Last reload type: Normal Reload

Last reload reason: Reload Command

–– часть информации удалена –

Cisco CISCO2901/K9 (revision 1.0) with 487424K/36864K bytes of memory.

Processor board ID FCZ1540C5LU

2 Gigabit Ethernet interfaces

1 terminal line

DRAM configuration is 64 bits wide with parity enabled.

255K bytes of non-volatile configuration memory.

255744K bytes of ATA System CompactFlash 0 (Read/Write)

License Info:

License UDI:

––

Device# PID SN

––

*0 CISCO2901/K9 FCZХХХХХХХ

Technology Package License Information for Module:'c2900'

––

Technology Technology-package Technology-package

Current Type Next reboot

––

ipbase ipbasek9 Permanent ipbasek9

security None None None

uc None None None

data None None None

Configuration register is 0x2102

Для установки времени используем следующие команды:

Устанавливаем время:

r1#clock set 08:00:00 Jan 2011

Часовой пояс:

r1(config)#clock timezone MSK+4

Задаем для маршрутизатора сервер времени:

r1(config)#ntp server 10.1.1.2

Данной командой маршрутизатор назначается сервером времени:

r2(config)#ntp master

Данная команда показывает время на нашем устройстве:

r1#show clock

Заставляет маршрутизатор обновлять часы по времени NTP-сервера:

r1(config)#clock update-calendar

Заставляет маршрутизатор задействовать внутренний календарь для получения эталонного времени:

r1(config)#clock calendar-valid

Подводим итог:

Для первоначальной настройки маршрутизатора или коммутатора мы должны ввести следующие команды и обязательно на подключенном к нашей сети интерфейсе указать адрес:

Router>enable

Router#conf t

Router(config)#hostname r1

r1(config)#interface F0/0

r1(config-if)#no shutdown

r1(config-if)#ip add 10.0.12.1 255.255.255.0

r1(config)#ip route 0.0.0.0 0.0.0.0 10.0.12.2

r1(config)#no ip domain-lookup

r1(config)#line console 0

r1(config-line)#exec-timeout 0 0

r1(config-line)#logging synchronous

r1(config-line)#exit

r1(config)#username admin privilege 15 secret cisco

r1(config)#ip domain-name cisco.net

r1(config)#crypto key generate rsa 2048

r1(config)#ip ssh version 2

r1(config)#line vty 0 4

r1(config-line)#login local

r1(config-line)#transport input telnet ssh

r1(config-line)#exit

r1(config)#exit

r1#clock set 08:00:00 Jan 2020

r1#write

Теперь мы можем подключиться к данному устройству по протоколам telnet и ssh с соседнего устройства, к примеру тут на него указан маршрут по умолчанию.

Коммутация

Виртуальная локальная сеть

Virtual

Local

Area

Network

(

Vlan

)

Для виртуально локальной сети (vlan) могут быть назначены номера от 1 до 1005, в прозрачном варианте (transparent) от 1 до 4094. Для Vlan можно назначить любое имя, но предпочтительнее называть их по их функциям, к примеру, admin ту, в которой работают администраторы и так далее:

Создаем виртуальную локальную сеть (vlan):

sw1(config)#vlan 234

Следующей командой задаем имя для данной виртуальной локальной сети:

sw1(config-vlan)#name VLAN234

sw1(config-vlan)#end

sw1#wr

Удалить виртуальную локальную сеть (vlan) можно простои командой no, пример приведён ниже:

sw1(config)#no vlan 234

Порт, предназначенный для одной виртуальной локальной сети, называется – портом доступа (access port). Порт настраивается следующими командами:

sw1(config)#interface f0/2

Назначаем порт портом доступа:

sw1(config-if)# switchport mode access

Задаем ему виртуальную локальную сеть (vlan):

sw1(config-if)# switchport access vlan 234

Проверить порт можно командой, показанной ниже:

sw1#show interface f0/2 switchport

Name: Fa0/2

Switchport: Enabled

Administrative Mode: static access

Operational Mode: static access

Administrative Trunking Encapsulation: negotiate

Operational Trunking Encapsulation: native

Negotiation of Trunking: Off

Access Mode VLAN: 234 (Support)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk associations: none

Administrative private-vlan trunk mappings: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

Пример создание двух виртуальных локальных сетей (vlan) и назначения им интерфейсов:

sw1(config)#vlan 5

sw1(config-vlan)#name vlan5

sw1(config-vlan)#vlan 43

sw1(config-vlan )#name vlan43

sw1(config-vlan)#exit

sw1(config)#interface FastEthernet0/5

sw1(config-if)#switchport access vlan 5

sw1(config-if)#interface FastEthernet0/24

sw1(config-if)#switchport access vlan 43

sw1(config-if)#end

sw1#wr

Посмотреть мы можем, командой:

sw1#show interface status

Port Name Status Vlan Duplex Speed Type

Fa0/1 notconnect 1 auto auto 10/100BaseTX

Fa0/2 notconnect 1 auto auto 10/100BaseTX

Fa0/3 connected 1 a-half a-10 10/100BaseTX

Fa0/4 notconnect 1 auto auto 10/100BaseTX

Fa0/5 vlan5 connected 5 a-half a-10 10/100BaseTX

Fa0/24 vlan43 connected 43 a-half a-10 10/100BaseTX

–– часть информации удалена –

Если мы хотим поменять одну виртуальную локальную сеть (vlan) на другую, делается это просто:

Для начала данная виртуальная локальная сеть (vlan) должна присутствовать на коммутаторе. Проверить виртуальную локальную сеть можно командой show vlan brief.

Ниже приведен пример команды:

sw1#show vlan brief

VLAN Name Status Ports

–– – – –

1 default active Fa0/6,Fa0/7,Fa0/8, Fa0/9

Fa0/11,Fa0/12,Fa0/13,Fa0/14

Fa0/15,Fa0/16,Fa0/17,Fa0/18

Gi0/1, Gi0/2

30 VLAN30 active

33 VLAN33 active

42 VLAN42 active

51 VLAN51 active Fa0/5

54 VALN54 active Fa0/4

234 VLAN234 active Fa0/2

243 VLAN243 active

300 VALN300 active Fa0/3

1002 fddi-default act/unsup

1003 trcrf-default act/unsup

Допустим, мы хотим установить, на интерфейс Fa0/3 vlan 30 для этого вводим следующие команды

sw1(config)#interface f0/3

sw1(config)#switchport access vlan 30

sw1(config)#exit

sw1#show vlan brief | i 30

30 VLAN30 active Fa0/3

После проверки мы видим, что на третьем интерфейсе вместо 300 находиться 30 виртуальная локальная сеть (vlan), ну соответственно мы должны обязательно сохранить наши изменения командой wr.

Магистральный протокол виртуальной локальной сети (VTP) Vlan Trunking Protocol

Протокол VTP используется для создания и управления виртуальными локальными сетями. Для настройки VTP перейдем в режиме конфигурирования и введем vtp

После ввода знака вопроса, мы видим, что мы можем настроить

sw1(config)#vtp ?

domain Set the name of the VTP administrative domain.

file Configure IFS file system file where VTP configuration is stored.

interface Configure interface as the preferred source for the VTP IP updater address.

mode Configure VTP device mode

password Set the password for the VTP administrative domain

pruning Set the administrative domain to permit pruning

version Set the administrative domain to VTP version

Добавив команду режим (mode) мы видим, что существует три модели настройки VTP:

sw2(config)#vtp mode ?

client Set the device to client mode.

server Set the device to server mode.

transparent Set the device to transparent mode

Режим прозрачный (transparent) поддерживает расширенные виртуальные локальные сети (vlans) от 1 до 4094. Он более удобен в использовании, так как в прозрачном режиме коммутатор только передает информацию и не применяет её к своей конфигурации.

 

Режим клиент (client)применяет к себе все настройки сделанные на сервере.

Режим сервер (server) предназначен для ввода и удаления новых виртуальных локальных сетей, на коммутаторах он установлен по умолчанию.

Показанный ниже утилита используется, только в режиме сервера (server) позволяет сократить трафик в сети. Но при этом очень сильно загружает коммутатор, который, является сервером:

sw1(config)#vtp pruning

Мы настраиваем свои коммутаторы так:

sw1(config)#vtp domain CISCO

sw1(config)#vtp mode transparent

sw1(config)#vtp password cisco

Не обязательно для VTP задавать домен и паспорт, но очень важно указать модель использования коммутатора, по умолчанию коммутатор находиться в режиме сервера (server).

Для проверки вводим команду, показанную ниже, и получаем:

sw1#show vtp status

VTP Version : running VTP2

Configuration Revision : 0

Maximum VLANs supported locally : 1005

Number of existing VLANs : 16

VTP Operating Mode : Transparent

VTP Domain Name : CISCO

VTP Pruning Mode : Disabled

VTP V2 Mode : Enabled

VTP Traps Generation : Disabled

MD5 digest : 0x07 0x4A 0x67 0xF3 0xA0 0x0E 0x9B 0xAD

Configuration last modified by 150.2.20.1 at 3-1-93 01:18:04

Данная ниже команда показывает заданный нами паспорт:

sw1#show vtp password

Конечно, настроить VTP область можно и так:

sw1(config)#vtp domain CISCO

sw1(config)#vtp mode server

sw1(config)#vtp password cisco

А на все другие коммутаторы сделать клиентами:

sw2(config)#vtp domain CISCO

sw2(config)#vtp mode client

sw2(config)#vtp password cisco

При данной модели, как уже было, написано все изменения можно будет вносить на сервере, и они будут применяться ко всем коммутаторам сети. Но данный вариант настройки имеет один недостаток, если в систему будет, поставлен коммутатор с более высоким номером Configuration Revision он, перестроит всю систему. Что приведет к выводу сети из строя.

Протокол VTP для маршрутизаторов, при наличии в нем модуля коммутатора, настраивается другим способом, пример приводиться ниже:

sw1#vlan database

sw1(vlan)#vtp transparent

sw1(vlan)#vtp domain cisco.com

sw1(vlan)#vtp password cisco

Также мы можем добавить нужные нам функции pruning и т.д.

sw1(vlan)#exit

sw1#wr

Подводим итог:

sw1#conf t

sw1(config)#vtp mode transparent

sw1(config)#exit

sw1#wr

Для нормальной работы коммутатора достаточно одной этой команды, все изменения по vlan мы будем вносить в наши коммутаторы сами.

1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18  19  20  21  22  23  24 
Рейтинг@Mail.ru